Problema al Instalar Apache

5061 visitas 6 respuestas

Hola he instalado el apache en windows vista y me pone este error:

Windows no pudo iniciar el servicio de Apache en el equipo local Error 1067: El proceso ha terminado de forma inesperada.

He instalado el apache con el Appserv 2.4.5.

Ademas cuando voy a ver el registro de error en la ruta donde tengo instalado el Apache:

C:\AppServ\apache\logs\error.log

No tengo ningún error escrito y el fichero me pone que no se ha tocado desde el 30/11/2005!

por desde Costa Rica

Registrado desde: 13 May 09

Respuestas

1 0

Hola alumailo,

Probablemente se trata de un error de permisos del directorio raiz de C:, prueba a instalarlo en D: o desactiva el control de cuentas de usuarios (UAC). Aunque ya te advierto que yo he cambiado a linux en mi portátil desesperado con los problemas de permisos q me daba la instalación de apache+php+mysql, por lo cual quizás no sea el más adecuado para darte consejos.

por desde España

Registrado desde: 07 Nov 07
0 0

Gracias por responder, pero ya lo tenia desactivado antes de instalar el appserv

por desde Costa Rica

Registrado desde: 13 May 09
1 0

Prueba entonces a instalarlo en D:, yo tuve q instalar en D el MySQL para q me funcionara

por desde España

Registrado desde: 07 Nov 07
0 0

hola he probado de cambiar la unidad y sigue sin irme esto ya es la polla en vinagre joder

por desde Costa Rica

Registrado desde: 13 May 09
0 0

Seguramente el problema fue resuelto, pero de todos modos dejo una posible solucion para quien tenga un problema similar.

Ese error suele aparecer cuando tiene problemas para iniciar un servicio. En este caso el de Apache.

Para comprobarlo debemos abrir el regedit (Tecla Windows+R -> escribir regedit) y una vez dentro buscar HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Services. Dentro de esa carpeta buscar Apache2.4 y observar si la clave ImagePath tiene bien escrita la ruta. O sea, si la ruta escrita es la misma que la ruta donde esta instalado nuestro Apache.

En caso de que no coincidan modificamos la entrada en el regedit y cambiamos la ruta.

Entonces, el error surge porque al querer iniciar el servicio de apache busca la ubicación en el regedit pero se da cuenta que no puede ubicar apache ya que esta en otro lado, o no esta en nuestra pc. Esto ocurre cuando instalamos varias veces el servidor sin desinstalar previamente otra versión o simplemente cuando borramos las carpetas directamente sin usar el desinstalador.

PD: Con mysql puede pasar lo mismo. La solucion es igual.

0 0

Hola, vale la pena revisar las rutas de los archivos http.conf y php.ini y validar que este habilitado que se muestren los errores:

error_reporting = E_ALL & ~E_NOTICE en php.ini